#4 Our carriers latest update is that initial observations are positive and customer retests show success when making outbound calls to EE. They will continue to monitor traffic levels into the working day tomorrow before fully closing the incident.
Posted Jul 24, 2025 - 21:11 BST
Monitoring
#3 Our carriers latest update is that EE confirmed they have made changes in a effort to restore services. They are monitoring traffic levels and asking customers to retest at this stage. From our initial testing calls now appear to be completing successfully, however we are still monitoring and will provide further information as it becomes available.
Posted Jul 24, 2025 - 20:44 BST
Update
#2 Our carriers latest update is that EE are continuing to investigate the issue on their network, and they are awaiting further updates from their investigation.
We will provide further information as it becomes available.
Posted Jul 24, 2025 - 19:17 BST
Update
#1 The issue is reported to be affecting some mobile numbers on EE, Vodafone, BT and O2 as well as other mobile carriers that rely on some of their infrastructure. Due to the way in which mobile porting works if a number previously existed on the EE network calls may route to their network in the first instance and cause them to fail. Several carriers have acknowledged an issue and have confirmed that they are working to resolve this.
We have reached out to our other carriers however they are experiencing the same issues, unfortunately due to the issue lying on mobile carrier networks this is out of our control, however we will continue to provide further information as it becomes available.
Posted Jul 24, 2025 - 15:02 BST
Identified
We are aware of an issue with some outbound PSTN calls to mobile numbers from the TeamsLink platform, we have raised this with the carrier who have confirmed that this is a known issue and has been raised with EE as a priority 1, this may also affect calls to some other mobile carriers. Inbound PSTN calls are unaffected.
We will provide further information as it becomes available.